Accueil Forums J’ai besoin d’aide Unity3D Animation/state

Ce sujet a 3 réponses, 3 participants et a été mis à jour par  Friedrich, il y a 5 mois et 3 semaines.

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #1098

    Friedrich
    Participant

    Salut !
    Alors voila, j’ai actuellement un projet en 2D j’ai fait les animations de mon personnage, j’en ai deux : Idle et marche.
    Avec l’animator j’ai réglé tout pour que quand je touche a rien l’animation “Idle” est par défaut et quand je me déplace l’animation “marche” se joue.
    Le soucis est que quand je test le personnage est bien en “idle” mais il y reste. Même en allant a gauche et a droite il reste en “idle”.
    Pourtant quand je regarde l’animator l’animation “marche” se joue bien quand je me déplace mais le perso reste en Idle. J’ai vérifié si dans “motion” mon animation “marche” etait bien selectionné pour l’etat de marche et oui. Alors je voit vraiment pas.
    Alors si quelqu’un a une idée je suis preneur merci a tous !

    #1101

    KiziLom
    Participant

    Salut, regarde si tu as bien décoché la case Has Exit Time.

    #1102

    renard
    Participant

    bonjour oui pour moi aussi je ne voie que ce probleme

    #1103

    Friedrich
    Participant

    Alors, oui les case etaient bien coché sur toute les transition.
    J’ai finalement recommencé depuis le debut et aucun soucis. Sa devait etre a force de faire des modi ici et la que j’ai du deregler quelque chose.
    Merci a vous 😉

4 sujets de 1 à 4 (sur un total de 4)

Vous devez être connecté pour répondre à ce sujet.