Quelle version d’Unity pour mon projet?

Lorsque l’on découvre le développement de jeux avec le moteur physique Unity, on a tendance a croire que la dernière version est « celle » a utiliser !

Et bien ce n’est pas forcement évident, bien au contraire ! D’ailleurs si vous suivez le « best pratice » , il est recommandé d’utiliser une version LTS d’unity (actuellement la 2018.4) .

Qu’est ce qu’une version L.T.S ?

En informatique, une version Long-term support ou LTS (en français Support à long terme) désigne une version spécifique d’un logiciel dont le support est assuré pour une période de temps plus longue que la normale.

Il s’agit de la mise en œuvre de la politique de gestion du cycle de vie d’un produit dans le domaine du génie logiciel, avec notamment l’application des principes de l’ingénierie de la fiabilité au processus de développement et de maintenance du logiciel. Le support à long terme étend la durée de la maintenance applicative ; il modifie également le type et la fréquence de publication des mises à jour (correctifs) pour réduire le risque, les dépenses et les perturbations liés au déploiement de logiciels, tout en favorisant la fiabilité.

Unity version LTS ?

La version Support à long terme (LTS) de Unity est destinée aux projets prêts à être publiés. Si vous souhaitez rester sur une version de Unity spécifique pour assurer un maximum de stabilité à votre production, alors Unity 2018.4 LTS est fait pour vous.

Le flux LTS est destiné aux utilisateurs qui souhaitent continuer à développer et à commercialiser leurs jeux/contenus et conserver une version stable pour une période étendue.

La version LTS ne contient pas de nouvelles fonctionnalités, de changements d’API ou d’améliorations. Elle traite les crash, les régressions et les problèmes qui affectent la communauté, notamment les erreurs des clients Enterprise Support, les SDK/XDK de console, ou toute modification majeure. Chaque flux LTS sera supporté pour une période de deux ans.

En conclusion

Tout dépendra de votre projet, mais si il ne doit pas impérativement utiliser des composants ou des outils disponibles uniquement dans la dernière version, il serait judicieux d’utiliser une version LTS afin d’éviter beaucoup de problème a l’avenir.Assurer l’évolution du code sur le long terme

Pour télécharger une version LTS : https://unity3d.com/fr/unity/qa/lts-releases

Si la version LTS ne vous suffit pas alors il existe aussi des version TECH stream qui sont destinées aux développeurs qui veulent accéder aux dernières fonctionnalités. Cette année, Unity en propose trois principales (2019.1, 2019.2 et 2019.3).


A propos de upln 201 Articles
En informatique le problème se situe souvent entre la chaise et le clavier !

Soyez le premier à commenter

Poster un Commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.